check engine 2.2 dti - mode dégradé

Boite de vitesses Carburants alternatifs Echappement Embrayage Moteur Préparation Turbo
Avatar de l’utilisateur
Locro
Messages : 124
Inscription : lun. nov. 20, 2006 1:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par Locro » mar. nov. 21, 2006 12:17 pm

Bonjour à tous,
Je suis nouveau sur le forum mais j'en suis à ma deuxième Saab.
Sur cette dernière,une 9.3 Tid 2.2 de 2001,j'ai des soucis de vanne EGR.
Ce n'est pas grave, il suffit de démonter et nettoyer,ce qui est plus embettant c'est d'éffacer le voyant et surtout de sortir du mode dégradé.
J'ai essayé de lire les codes EOBD avec un scaner multi-protocoles,il a l'air de reconnaitre le protocole ISO PKW2000 mais n'affiche aucun code DTC (O) et si je fait quant même Erase il n'y arrive pas.
Je sais que l'EOBD n'a été imposé qu'a partir de 2003 sur les diesels mais toutes les publications donnent Saab comme étant compatible dès 2001.
Je cherche donc à localiser le calculateur pour en connaitre le type. Faut-il démonter le cache au dessus des pédales ?
Normalement ce devrais être un Bosh EDC15M vue le moteur (X22DTH ou Y22DTH Opel ) si qq peut me le
confirmer ? Si c'est lui il est compatible EOBD et ça voudrai dire que mon scaner a un pb ce qui est aussi possible.
Ou faut-il une interface Tech2 ? Sur la prise les pines 4,5,7,8,16 sont cablées, à part la 8 en trop, cela correspond à un cablage EOBD. Je vais faire une recherche sur le brochage du Tech2.
Tout çà parceque mon concess me prend 27€ pour me sortir du mode dégradé :fou: ou 900€ pour sa solution miracle qui est de me changer la vanne :kaola: et si il lui vient à l'idée de nettoyer le circuit d'admission complet alors là on s'envole vers les 1500€. :cry:
Heureusement que je n'ai pas le FAP ! :)

Avatar de l’utilisateur
jcinfo
Messages : 3077
Inscription : sam. nov. 19, 2005 1:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par jcinfo » jeu. nov. 23, 2006 12:48 am

Salut, le protocol et bien ODB mais specifique a Saab, on a fait un post la dessus j'arrive pas a le lire avec mon iso nonp lus pour le moment.

Avatar de l’utilisateur
Locro
Messages : 124
Inscription : lun. nov. 20, 2006 1:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par Locro » jeu. nov. 23, 2006 1:39 pm

Personne n'a fait d'essais avec ce que l'on appel "interface Tech2" pour pc que l'on trouve dans le commerce ?

Avatar de l’utilisateur
jcinfo
Messages : 3077
Inscription : sam. nov. 19, 2005 1:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par jcinfo » jeu. nov. 23, 2006 2:14 pm

Le tech2 iso et pour opel et sa marcherras pas non plus sur un model europeen. Y a que l'iso au US qui marche comem je l'avias dejas expliquer.

Avatar de l’utilisateur
kodovoltas
Messages : 352
Inscription : lun. août 07, 2006 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par kodovoltas » jeu. nov. 23, 2006 7:09 pm

Le tech2 iso et pour opel et sa marcherras pas non plus sur un model europeen. Y a que l'iso au US qui marche comem je l'avias dejas expliquer.
C'est dur de te lire !
Tu as un problème de clavier ? :whistle:
Ou le cerveau qui va plus vite que les doigts ? :lol:

Sans méchanceté aucune ! :ange:

Juste pour rigoler un peu ... :hello:

OK, je suis déjà sorti . . .

Avatar de l’utilisateur
jcinfo
Messages : 3077
Inscription : sam. nov. 19, 2005 1:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par jcinfo » jeu. nov. 23, 2006 9:24 pm

Oui désoler j'inverse souvent au clavier.

Avatar de l’utilisateur
Locro
Messages : 124
Inscription : lun. nov. 20, 2006 1:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par Locro » jeu. déc. 14, 2006 1:04 am

voir retour d'experience sur le post obd (c'est pas si neg que ça)

rrc-phil
Messages : 25
Inscription : dim. juin 03, 2007 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par rrc-phil » ven. juil. 06, 2007 8:25 pm

plusieurs questions:

1/le voyant de chauffe, de ma 93 tid 125cv, ne s'allume pas et la voiture est plus difficile à mettre en route, plusieurs secondes sur le démarreur...
donc apparemment la chauffe ne marche pas!!!
a une exception près, lorsque je vais dans ma belle famille à Chamonix, où la le voyant s'allume et la voiture démarre au quart de tour.
mes 2 derniers deplacements à Chamonix étaient au mois d'avril et de juin, donc je ne pense pas qu'il y ait de corrélation avec la température.

est-ce qu'il y aurait une sonde qui serait sensible à l'altitude ou la pression atmosphérique, ou à ma belle-soeur, qui commanderait la mise en route de la chauffe?

2/j'ai un boitier de gain de puissance, plutot agréable, si ce n'est que lorsque j'accélere trop fort, le moteur se met en sécurité!!!

j'avais déjà eu le probleme avant de monter le boitier et lorsque la voiture était encore sous garantie et le mécano chez SAAB avait juste démonté une sonde et l'avait néttoyée.
est ce que cela vous dit quelque chose?

merci de vos avis éclairés, sauf sur ma belle-soeur.....

Avatar de l’utilisateur
BRICOLOSAAB
Messages : 379
Inscription : mer. mai 23, 2007 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par BRICOLOSAAB » sam. juil. 07, 2007 1:59 pm

je pense que le voyant de chauffe ne s'allume pas l'été, pour la voiture qui ne démarre pas de suite, il s'agit pour moi d'une prise d'air sur un tuyeau de retour de gazoil

Avatar de l’utilisateur
fenderoad
Messages : 919
Inscription : ven. mai 05, 2006 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par fenderoad » sam. juil. 07, 2007 4:38 pm

le voyant s'allume (et les bougies chauffent), si t° ldr < 5°C,

c'est le manuel qui le dit...

jezant
Messages : 112
Inscription : ven. avr. 14, 2006 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par jezant » sam. juil. 07, 2007 9:14 pm

prise d'air sur le circuit de GO 35-45€ ca vaut pas le coup de bousiller ton démarreur va faire la réparation tout de suite.....
t'es encore là??? FILE!!!!!!!!!!!!!!!!!!!!!!!!

rrc-phil
Messages : 25
Inscription : dim. juin 03, 2007 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par rrc-phil » dim. juil. 08, 2007 6:06 pm

ok sur la prise d'air pour le GO, c'est sur le retour, c'est bien ca?

pour le voyant de chauffe, je suis plus surpris, il ne s'est pas allumé de l'hiver et bien que l'hiver n'est pas été rigoureux, nous avons quand meme eu des gelées...

en plus la derniere fois qu'il s'est allumé à Chamonix, c'était en journée et sans que ce soit les grandes chaleurs, il faisait bon, et là, la voiture a vraiement démarré au 1/4 de tour.

Avatar de l’utilisateur
guillaume91090
Messages : 206
Inscription : ven. juil. 20, 2007 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par guillaume91090 » mar. oct. 23, 2007 1:30 pm

Pour commencer je tiens à annoncer qu’il s’agit d’une contribution d’un amateur et non d’un professionnel, donc merci de la prendre avec précaution.

1) Au sujet du voyant moteur :

Ce voyant peut s’allumer pour de nombreuses raisons, à chaque fois que l’ordinateur (pas le SID, le calculateur moteur le truc à ne pas démonter sans connaissances !!!) détecte un problème au sein du fonctionnement du moteur. J’entends donc qu’une multitude de possibilités ou plutôt de merdouilles peut mettre notre chèr diesel en mode dégradé (tracteur) ; en voici quelques exemples :
- une bougie de préchauffage qui fonctionne mal
- le débimètre de cassé ou encrassé
- la vanne EGR qui reste bloquée
- de la saleté dans le collecteur d’admission d’air
- un filtre à air très très sale
- …

Lorsque ce voyant s’allume il se peut que la voiture ne rentre pas en mode dégradé, (par exemple pour une bougie de préchauffage). Le mode dégradé permet d’économiser notre auto et d’éviter la casse.

2) Les codes erreurs :

A chaque fois que ce voyant s’allume, notre petite saab est intelligent et enregistre le code erreur que l’ordinateur lui à transmis.

Via le tech2 ou une prise de diagnostic il est possible de relever les (10 derniers il me semble) codes erreurs gardés en mémoire et en ordre par notre voiture.

Ces codes erreurs vont nous indiquer un défaut dans le circuit EGR, ou un défaut vers l’entrée d’air et bien d’autre…

Il s’agit d’un outil formidable mais qui reste à prendre avec précaution car ce défaut annoncé peut être la cause d’un autre problème (nombreux sont les personnes qui se voient changer un débimètre vu le code défaut alors que c’est une durite poreuse qui traine…

Alors lisez ces codes mais restez prudent tout de même…


3) La recherche manuelle de panne (assisté c’est mieux par les codes erreurs) :

Il peut être intéressant de se porter déjà sur les codes erreurs pour vérifier les pièces défectueuses.

Personnellement :
Voici à mon sens les étapes à suivre :
- vérifier l’état de son filtre à air et l’état d’entrée d’air des conduits
- vérifier l’état de propreté du débimètre avec dans l’idéal un débimètre de test (neuf ou complètement cassé) pour voir si il y a changement.
- Contrôler l’intégralité du circuit de dépression avec un contrôle visuel de l’ensemble des durites… et c’est pas tout !!! Vérifier que l’ensemble des électrovannes fonctionnement correctement.
- Vérifier que le turbo tourne et est bien commandé
- Vérifier que la vanne EGR est bien commandé par le circuit de dépression$
- Vérifier que la capsule de turbulence ne merdouille pas
- Si tout est bon il est temps de préparer le nettoyage de la vanne et du collecteur d’admission…

Après tout ça je pense que vous devriez réussir à trouver la source du problème. Si ce n’est pas le cas cela peut être plus « grave » (problème turbo, injecteur,…) mais cela est théoriquement annoncé dans les codes erreurs qui l’a sont souvent beaucoup plus sûrs.

Je tacherais de compléter ce post par des explications pour chacun des points invoqués précédemment.

De l’aide est toujours la bien venue, alors n’hésitez pas !!!

Désolé pour les fautes d'ortho.. ;-)

Avatar de l’utilisateur
tof
Messages : 232
Inscription : mer. août 29, 2007 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par tof » mar. oct. 23, 2007 7:20 pm

il y a aussi la sonde de pression dans le collecteur d'admission qui s'encrasse ;)

Avatar de l’utilisateur
tazoux
Messages : 595
Inscription : dim. mars 25, 2007 1:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par tazoux » mar. oct. 23, 2007 7:54 pm

la sonde lamda aussi

Avatar de l’utilisateur
fenderoad
Messages : 919
Inscription : ven. mai 05, 2006 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par fenderoad » mar. oct. 23, 2007 10:20 pm

très bien vu ton post Guillaume :hello:

juste une petite suggestion : un changement de titre genre "lecture des codes check engine 2.2 TID" me paraîtrait plus judicieux et lisible que parler d'un moteur dti opel... ;)

très intéressant en tous cas !

saabistement

chacha1
Messages : 33
Inscription : jeu. mars 30, 2006 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par chacha1 » sam. sept. 12, 2009 9:55 am

bonjour a vous tous ,voila cinq ans que je roule avec ma 9.3 tid 115ch sans aucun probleme mise a part la pompe a eau qui fuyait par le petit trou et donc que j'ai changé ,il faut dire quelle affiche quand meme 244000km . Mais depuis peu j'ai ce fameux voyant qui s'allume ,j'ai donc suivi vos conseils démontage pipe d'admition vanne EGR et je vous dit pas l'etat de tout cela apres autant de kilometres allucinant le dépot c'est a ce demander comment les papillons pouvaient s'ouvrir ,nettoyage de la sonde a droite de la pipe d'admition .Le probleme c'est que ce voyant de sécuritée moteur s'allume assez souvent je n'ai pas remarquer de baisse de puissance par contre des que j'arrive a 3200trmin le voyant s'eteint et quan le régime baisse il se r'allume .Qui a déja eu ce phénomène ? Et d'après vous de quoi cela peu venir ?
MERCI d'avance

Avatar de l’utilisateur
volcano15
Messages : 241
Inscription : dim. avr. 15, 2007 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par volcano15 » ven. sept. 18, 2009 1:47 am

Bonsoir a tous,
concernant le fonctionnement en mode dégradé,est il possible d'avoir une perte de puissance(150 maxi sur autoroute),pas ou peu de reprise,un régime moteur plafonnant a 3000/3500 t,tout cela sans allumage du voyant check engine?
Il faut dire que je conduit ma tid a une allure de sénateur(passage des vitesses a 2000t/mn).
Pensez vous qu elle puisse etre encrassée(vanne egr)?Ce qui m'intrigue le plus c'est qu'il n'y a pas d'allumage du voyant.

Avatar de l’utilisateur
scania
Messages : 2409
Inscription : mer. déc. 08, 2004 1:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par scania » ven. sept. 18, 2009 10:58 am

Pour ce que j'en sais, sur mon 115 la vanne est nettoyée à chaque vidange (10 000kms). En recoupant de nombreux posts, une bonne accèle de temps en temps c'est pas mal. Volcano, ta vanne egr doit être bien encrassée, par acquis de conscience tu devrais la nettoyer...

Avatar de l’utilisateur
volcano15
Messages : 241
Inscription : dim. avr. 15, 2007 2:00 am
Contact :

Re: check engine 2.2 dti - mode dégradé

Message par volcano15 » ven. sept. 18, 2009 1:29 pm

Est ce que tu pense que la vanne egr peut etre encrassée sans allumer le check engine?

Répondre

Revenir à « mécanique »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité